Biostar Beta. Not for public use.
GATK gradlew bundle Error
0
Entering edit mode
12 months ago
Karachi, PK

While building gatk

sudo ./gradlew bundle

Downloading https://services.gradle.org/distributions/gradle-3.1-bin.zip

Exception in thread "main" javax.net.ssl.SSLException: java.security.ProviderException: java.security.InvalidKeyException: EC parameters error at sun.security.ssl.Alerts.getSSLException(Alerts.java:208) at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1914) at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1872) at sun.security.ssl.SSLSocketImpl.handleException(SSLSocketImpl.java:1855) at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1376) at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1353) at sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:559) at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:185) at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1366) at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:263) at org.gradle.wrapper.Download.downloadInternal(Download.java:58) at org.gradle.wrapper.Download.download(Download.java:44) at org.gradle.wrapper.Install$1.call(Install.java:61) at org.gradle.wrapper.Install$1.call(Install.java:48) at org.gradle.wrapper.ExclusiveFileAccessManager.access(ExclusiveFileAccessManager.java:69) at org.gradle.wrapper.Install.createDist(Install.java:48) at org.gradle.wrapper.WrapperExecutor.execute(WrapperExecutor.java:107) at org.gradle.wrapper.GradleWrapperMain.main(GradleWrapperMain.java:61) Caused by: java.security.ProviderException: java.security.InvalidKeyException: EC parameters error at sun.security.pkcs11.P11Key$P11ECPublicKey.getEncodedInternal(P11Key.java:1024) at sun.security.pkcs11.P11Key.equals(P11Key.java:158) at java.util.ArrayList.indexOf(ArrayList.java:302) at java.util.ArrayList.contains(ArrayList.java:285) at sun.security.validator.PKIXValidator.engineValidate(PKIXValidator.java:239) at sun.security.validator.Validator.validate(Validator.java:260) at sun.security.ssl.X509TrustManagerImpl.validate(X509TrustManagerImpl.java:326) at sun.security.ssl.X509TrustManagerImpl.checkTrusted(X509TrustManagerImpl.java:231) at sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(X509TrustManagerImpl.java:126) at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1459) at sun.security.ssl.ClientHandshaker.processMessage(ClientHandshaker.java:213) at sun.security.ssl.Handshaker.processLoop(Handshaker.java:961) at sun.security.ssl.Handshaker.process_record(Handshaker.java:897) at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1033) at sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1342) at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1369) ... 13 more Caused by: java.security.InvalidKeyException: EC parameters error at sun.security.ec.ECParameters.getAlgorithmParameters(ECParameters.java:284) at sun.security.ec.ECPublicKeyImpl.(ECPublicKeyImpl.java:59) at sun.security.pkcs11.P11Key$P11ECPublicKey.getEncodedInternal(P11Key.java:1021) ... 28 more Caused by: java.security.NoSuchProviderException: no such provider: SunEC at sun.security.jca.GetInstance.getService(GetInstance.java:83) at sun.security.jca.GetInstance.getInstance(GetInstance.java:206) at java.security.Security.getImpl(Security.java:697) at java.security.AlgorithmParameters.getInstance(AlgorithmParameters.java:199) at sun.security.ec.ECParameters.getAlgorithmParameters(ECParameters.java:279)

ADD COMMENTlink
1
Entering edit mode
13 months ago
WCIP | Glasgow | UK

I surmise this has nothing to do with GATK but with gradle. Googling java.security.ProviderException: java.security.InvalidKeyException: EC parameters leads to this issue which suggests OpenJDK7 is the culprit. As suggested there, try upgrading to OpenJDK8 in case you are also on 7. This is, of course, a wild guess from me...!

ADD COMMENTlink
0
Entering edit mode

Thank you dariober, it works

sudo apt-get update
sudo apt-get install openjdk-8-jdk

sudo update-alternatives --config java
sudo update-alternatives --config javac

and enter the number for which JDK to use of your choice.
ADD REPLYlink

Login before adding your answer.

Similar Posts
Loading Similar Posts
Powered by the version 2.1