Biostar Beta. Not for public use.
install obitools error
1
Entering edit mode
3.0 years ago
liu_ming_xin • 10
@liu_ming_xin36915

Hello,

I was using command $python get-obitools.py to install the obitools in Ubuntu 16.04.1 LTS x86_64. Just fail to successfully install in my laptop. The error reports like below:

/tmp/tmpzfS5CP/obitools.zip Traceback (most recent call last): File "get-obitools.py", line 45234, in <module> main() File "get-obitools.py", line 45171, in main filename = pypidownload() File "get-obitools.py", line 45156, in pypidownload pip = get_a_pip_module() File "get-obitools.py", line 45095, in get_a_pip_module pipmodule = importlib.import_module('pip') File "/usr/lib/python2.7/importlib/__init__.py", line 37, in import_module __import__(name) File "/tmp/tmpzfS5CP/obitools.zip/pip/__init__.py", line 11, in <module> File "/tmp/tmpzfS5CP/obitools.zip/pip/vcs/mercurial.py", line 9, in <module> File "/tmp/tmpzfS5CP/obitools.zip/pip/download.py", line 22, in <module> File "/tmp/tmpzfS5CP/obitools.zip/pip/_vendor/requests/__init__.py", line 53, in <module> File "/tmp/tmpzfS5CP/obitools.zip/pip/_vendor/requests/packages/urllib3/contrib/pyopenssl.py", line 70, in <module> AttributeError: 'module' object has no attribute 'PROTOCOL_SSLv3'

I am very grateful if someone can help me out. Thanks in advance, guys.

Cheers, Mingxin

obitools ubuntu next-gen metabarcoding • 1.9k views
ADD COMMENTlink
1
Entering edit mode
4.0 years ago
@frederic.boyer37112

Hi,

there is a bug in the install script for Ubuntu 16.04.

Just follow the next lines to install the obitools :

## go to your home dir or wherever you want
cd

## create a virtual env with python 2.7
mkdir OBI
cd OBI
virtualenv-2.7 OBI-env

## get and extract the source
wget 'https://git.metabarcoding.org/obitools/obitools/repository/archive.tar.gz?ref=master'
tar -zxvf "archive.tar.gz?ref=master"

## activate the virtual env
source OBI-env/bin/activate

## last sphinx version has a problem, install one that is OK
pip install sphinx==1.4.8

## enter the source folder
cd obitools-master-*

## build the package
python setup.py build

## install it in the virtual env
python setup.py install

## leave the virtualenv
deactivate

At this point the software should be installed within the OBI directory, just add the bin directory in your PATH

## add this line in your .bashrc
## to enable the OBITools

export PATH=${PATH}:"~/OBI/OBI-env/bin"

regards

ADD COMMENTlink
0
Entering edit mode

Hi Frederic,

Thank you very much. It really solved my problem.

Cheers, Mingxin

ADD REPLYlink
0
Entering edit mode

Hi, i tried to follow the steps described above, I am using ubuntu 16.04 and I am getting this error:

error in OBITools setup command: 'install_requires' must be a string or list of strings containing valid project/version requirement specifiers; Invalid requirement, parse error at "'and <6'" can the problem be solved? thanks a lot

ADD REPLYlink
1
Entering edit mode
3.0 years ago
jojoezz • 10
@jojoezz45014

Hello I tried all the above suggestion but no luck. But someone helped me and I would like to share how it worked for me.

1) First, you need to install pip, in case you don't have it:

sudo apt-get install python-pip

2) Then install the biopython dependencies:

sudo pip install biopython

3) Then, simply install the OBITools python package. It will automatically install virtualenv, cython and sphinx:

sudo pip install obitools

(Probably, you will get some warnings and "compiling errors". But the OBITools will still work.)

To test if the OBITools have been properly installed, then try to write in the command line, for example:

obicount --help

And if you get the help screen of the command, then everything's working OK.

I hope it will work for you

ADD COMMENTlink
0
Entering edit mode
3.4 years ago
calvi.c • 0
@calvi.c42162

The answer above also solved my problem once (thanks!), but when I tried to install it on Ubuntu 16 LTS, it didn t work any more. Error:

error in OBITools setup command: 'install_requires' must be a string or list of strings containing valid project/version requirement specifiers; Invalid requirement, parse error at "'and <6'"

In a bioinformatics group I got the message that apparently, there is a bug in the installation script of OBITools when run in Ubuntu 16.

One way was to go back to Ubuntu 14, but that s not a good long term solution.

ADD COMMENTlink
0
Entering edit mode

I got the same 'install_requires' error when trying to install obitools as in the answer above on Ubuntu 16.04. Following the steps at Downloading and installing the OBITools section from the official page solved the problem for me.

ADD REPLYlink

Login before adding your answer.

Similar Posts
Loading Similar Posts
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.3