Biostar Beta. Not for public use.
venndiagram `Error in draw.quintuple.venn`?
1
Entering edit mode
13 months ago
star • 150
Netherlands

I have tried to draw a Venn diagram like below, but I faced with Error :

'ERROR [2019-04-01 17:10:26] Impossible: a2 <- area2 - a9 - a10 - a19 - a20 - a21 - a11 - a28 - a29 - a31 - a22 - a30 - a26 - a25 - a24 - a14 produces negative area. Error in draw.quintuple.venn(area1 = 327498, area2 = 30526, area3 = 639, : Impossible: a2 <- area2 - a9 - a10 - a19 - a20 - a21 - a11 - a28 - a29 - a31 - a22 - a30 - a26 - a25 - a24 - a14 produces negative area'.

grid.newpage()
venn.plot <- draw.quintuple.venn(
area1 = 327498,
area2 = 30526,
area3 = 639,
area4 = 2000,
area5 = 49925,
n12 = 34944,
n13 = 130,
n14 = 305,
n15 = 31838,
n23 = 350,
n24 = 1014,
n25 = 19339,
n34 = 64,
n35 = 214,
n45 = 932,
n123 = 57,
n124 = 267,
n125 = 12847,
n134 = 3,
n135 = 31,
n145 = 179,
n234 = 41,
n235 = 186,
n245 = 706,
n345 = 30,
n1234 = 3,
n1235 = 22,
n1245 = 189,
n1345 = 3,
n2345 = 27,
n12345 = 3,
category = c("A", "B", "C", "D", "F"),
fill = c("dodgerblue", "goldenrod1", "darkorange1", "seagreen3", "orchid3"),
cat.col = c("dodgerblue", "goldenrod1", "darkorange1", "seagreen3", "orchid3"),
cat.cex = 2,
margin = 0.05,
cex = c(1.5, 1.5, 1.5, 1.5, 1.5, 1, 0.8, 1, 0.8, 1, 0.8, 1, 0.8, 1, 0.8, 
      1, 0.55, 1, 0.55, 1, 0.55, 1, 0.55, 1, 0.55, 1, 1, 1, 1, 1, 1.5),
ind = TRUE
)

Thanks for your help in advance!

R venndiagram • 194 views
ADD COMMENTlink
3
Entering edit mode
13 months ago
H.Hasani • 730
Freiburg, Germany

why not simply use Vennerable with method "AWFE"

to be clear, the error indicates a miscalculation in the intersect areas. If you want, you can use the function Venn from the mentioned library and use these numbers. I would simply plot the resulted venn using plot(..., type = "AWFE").

hth

ADD COMMENTlink

Login before adding your answer.

Similar Posts
Loading Similar Posts
Powered by the version 2.1