Biostar Beta. Not for public use.
perl script 'blast_rod_finder.pl' not giving output but no errors either
0
Entering edit mode
2.3 years ago
Lau • 0

Hi, I apologize about this question in case its easy answer, I have been trying to run this script written in perl blast_rod_finder.pl (https://github.com/aleimba/bac-genomics-scripts/tree/master/rod_finder), which finds regions of difference between two genomes. It should be pretty straight forward but when I run it nothing happens. It should give back a folder with the results but that's not the case and is not giving me any errors so not sure how to figure out whats going wrong. I checked and all my bioperl modules are there... any tips greatly appreciated.

This is the script I am using:

perl blast_rod_finder.pl -q CarnobacteriummaltaromaticumSKLD3.gbk -r CarnobacteriummaltaromaticumSKLD3_blastout -m 2000

-q is GBK file of the query -r blast output between query and a reference genome![enter image description here -m is size

ADD COMMENTlink
0
Entering edit mode
2.0 years ago
YaGalbi ♦ 1.4k
Biocomputing, MRC Harwell Institute, Ox…

Did you check your home or in the folder that contains the script? Some programs print output there unless you give a full output path

This looks like where you choose output folder location:

### Create results directory, where output files are written to
my $out_dir = './results/';
if (-e $out_dir) {
    print "\n\n###Directory \'$out_dir\' already exists! Replace the directory and all its contents? [y|n] ";
    my $user_ask = <STDIN>;
    if ($user_ask =~ /y/i) {
    unlink glob $out_dir."*"; # remove all files in results directory
    rmdir $out_dir; # remove the empty directory
    } else {
    die "Script abborted!\n";
    }
}
mkdir $out_dir or die "Can't create directory \"$out_dir\": $!\n";

Are you getting any of the messages here printed to your terminal?

Try:

    my $out_dir = 'full/path/to/results/';
ADD COMMENTlink
0
Entering edit mode

Thanks, for the tips, I think the script must not be running because I added a message and is not showing up, even if I run the script alone it doesn't do anything. Sorry I am not used to perl so not sure how to tackle this

ADD REPLYlink
0
Entering edit mode

I tried this change, but I think the problem is the script is not running because there are no messages appearing in the terminal

ADD REPLYlink
0
Entering edit mode

I just realized what was happening, it was really simple, thanks!

ADD REPLYlink
0
Entering edit mode

I just realized what was happening, it was really simple, thanks!

And what was solution, to provide closure to this question?

ADD REPLYlink

Login before adding your answer.

Similar Posts
Loading Similar Posts
Powered by the version 2.3.1