Biostar Beta. Not for public use.
meme-chip command line usage error
0
Entering edit mode
18 months ago
varsha619 • 80

Hello, I have used meme-chip before in the online tool and works great but tried to do the same in command line -

meme-chip -oc . -time 300 -order 1 -db db/FLY/fly_factor_survey.meme -db db/FLY/idmmpmm2009.meme -db db/FLY/flyreg.v2.meme -db db/FLY/OnTheFly_2014_Drosophila.meme -db db/FLY/dmmpmm2009.meme -meme-mod zoops -meme-minw 6 -meme-maxw 30 -meme-nmotifs 3 -dreme-e 0.05 -centrimo-score 5.0 -centrimo-ethresh 10.0 input.fa

I downloaded the meme db folder to the local folder as well but still get this error -

Log::Log4perl configuration looks suspicious: No loggers defined at /apps/perl/perls/perl-5.16.0/lib/site_perl/5.16.0/Log/Log4perl/Config.pm line 322. Unknown option: order The sequences specified do not exist.

It looks like a perl error but I am not too familiar with perl. Has anyone else faced this/ know how to fix it? Thank you for your help!

meme-chip • 902 views
ADD COMMENTlink
0
Entering edit mode

Is meme-chip completing or exiting?

ADD REPLYlink
0
Entering edit mode

It is exiting and there are no output files, thanks.

ADD REPLYlink
1
Entering edit mode
19 months ago
Hussain Ather • 920
National Institutes of Health, Bethesda…

Make sure that Log::Log4Perl is installed correctly.

ADD COMMENTlink
0
Entering edit mode

To do so, use the command cpan.

ADD REPLYlink
0
Entering edit mode

I will try to do this, thank you!

ADD REPLYlink
0
Entering edit mode
15 months ago
Malcolm.Cook ♦ 1.0k
kansas, usa

I don't think the message about Log4perl is the real issue.

I would expect some form of disaster passing a period in -oc . to meme-chip as you do.

Pass in string to name the directory you want created to place the results

ADD COMMENTlink
0
Entering edit mode
18 months ago
varsha619 • 80

MEME-ChIP runs if I remove '-order 1' from the command, I am not exactly sure why. It still gives the log4perl error but completes the run now.

ADD COMMENTlink
1
Entering edit mode

i run mem-chip alot...and I always have that log4perl error...it does not effect your results

ADD REPLYlink
0
Entering edit mode

Ah I see, thank you!

ADD REPLYlink
1
Entering edit mode

Also, the default is order 1 anyway.

ADD REPLYlink

Login before adding your answer.

Similar Posts
Loading Similar Posts
Powered by the version 2.3